Answered By: Heather Maez
Last Updated: Aug 17, 2016     Views: 3

This message usually means that the browser needs to be updated:

  • Older browsers may not work because they are unable to perform the 128-bit encryption or confirm the security certificates which is required to use resources off-campus
  • A common fix for this is to upgrade your current web browser or install and use a different browser such as Internet Explorer, Firefox, Safari, or Chrome